openSUSE 12.x 安裝缺少的多媒體codecs

 

sudo zypper install libxine2-codecs k3b-codecs ffmpeg lame gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2
正在建立套件庫 'Packman' 的快取 ..........................................[完成]
正在載入套件庫資料...
讀取已安裝的套件...
'gstreamer-0_10-plugins-bad' 已經安裝。
有更新候選為 'gstreamer-0_10-plugins-bad',但它是從不同供應者提供。使用 'zypper install gstreamer-0_10-plugins-bad-0.10.23-19.32.x86_64' 來安裝這個更新。
正在解決套件相依性...
2 問題:
問題: ffmpeg-1.0.6-1.1.x86_64 需要 libpostproc52 = 1.0.6,但無法提供此需求
問題: k3b-codecs-2.0.2-15.48.x86_64 需要 k3b = 2.0.2-15.48,但無法提供此需求

問題: ffmpeg-1.0.6-1.1.x86_64 需要 libpostproc52 = 1.0.6,但無法提供此需求
  無法安裝的提供者: libpostproc52-1.0.6-1.1.i586[Packman]
                   libpostproc52-1.0.6-1.1.x86_64[Packman]
解決方案 1:安裝 libpostproc52-1.0.6-1.1.x86_64 (並變更廠商)
  VideoLAN Project (http://www.videolan.org)  -->  http://packman.links2linux.de
解決方案 2:請勿安裝 ffmpeg-1.0.6-1.1.x86_64
解決方案 3:請勿安裝 ffmpeg-1.0.6-1.1.x86_64
解決方案 4:藉由忽略某些它的相依性破壞 ffmpeg-1.0.6-1.1.x86_64

使用'數字'選擇上列的解決方法,或 skip(跳過)、retry(重試)或 cancel(取消) [1/2/3/4/s/r/c] (c): 2

問題: k3b-codecs-2.0.2-15.48.x86_64 需要 k3b = 2.0.2-15.48,但無法提供此需求
  無法安裝的提供者: k3b-2.0.2-15.48.i586[Packman]
                   k3b-2.0.2-15.48.x86_64[Packman]
解決方案 1:下列行動將被執行:
  降級 k3b-2.0.2-26.1.2.x86_64 到 k3b-2.0.2-15.48.x86_64
  安裝 k3b-2.0.2-15.48.x86_64 (並變更廠商)
    openSUSE  -->  http://packman.links2linux.de
解決方案 2:請勿安裝 k3b-codecs-2.0.2-15.48.x86_64
解決方案 3:請勿安裝 k3b-codecs-2.0.2-15.48.x86_64
解決方案 4:藉由忽略某些它的相依性破壞 k3b-codecs-2.0.2-15.48.x86_64

使用'數字'選擇上列的解決方法,或 skip(跳過)、retry(重試)或 cancel(取消) [1/2/3/4/s/r/c] (c): 1
正在解析相依性...
正在解決套件相依性...

將會安裝下列新的套件:
  gstreamer-0_10-plugins-ffmpeg gstreamer-0_10-plugins-ugly
  gstreamer-0_10-plugins-ugly-orig-addon k3b-codecs lame libavcodec52
  libavfilter1 libavformat52 libavutil50 libpostproc51 librtmp0 libsidplay1
  libswscale0 libx264-129 libxine2 libxine2-codecs

下列套件將會升級:
  libdvdcss2

下列套件將會降級:
  k3b

下列套件將會變更供應商:
  k3b  openSUSE -> http://packman.links2linux.de


1  套件將升級, 1  將降級, 16  新的, 1  將變更供應商.
全部下載大小: 12.6 MiB。 完成操作後,將增加 17.4 MiB 的使用。
要繼續嗎? [y/n/?] (y): y
正在取出 套件 libavutil50-0.7.15-1.4.x86_64 (1/18),  54.0 KiB (已解開 108.8 KiB)
正在取出: libavutil50-0.7.15-1.4.x86_64.rpm ................[完成 (13.9 KiB/s)]
正在取出 套件 libx264-129-0.129svn20130224-2.1.x86_64
                                            (2/18), 318.3 KiB (已解開 847.4 KiB)
正在取出: libx264-129-0.129svn20130224-2.1.x86_64.rpm .....[完成 (139.8 KiB/s)]
正在取出 套件 lame-3.99.5-1002.1.x86_64     (3/18),  47.5 KiB (已解開  96.9 KiB)
正在取出: lame-3.99.5-1002.1.x86_64.rpm .................................[完成]
正在取出 套件 librtmp0-2.4.git20121102-1.1.x86_64
                                            (4/18),  60.9 KiB (已解開 133.2 KiB)
正在取出: librtmp0-2.4.git20121102-1.1.x86_64.rpm .......................[完成]
正在取出 套件 libxine2-1.2.3-84.1.x86_64    (5/18),   2.2 MiB (已解開   5.5 MiB)
正在取出: libxine2-1.2.3-84.1.x86_64.rpm ..................[完成 (502.0 KiB/s)]
正在取出 套件 k3b-2.0.2-15.48.x86_64        (6/18),   6.0 MiB (已解開  13.8 MiB)
正在取出: k3b-2.0.2-15.48.x86_64.rpm ......................[完成 (570.1 KiB/s)]
正在取出 套件 libswscale0-0.7.15-1.4.x86_64 (7/18),  77.9 KiB (已解開 234.4 KiB)
正在取出: libswscale0-0.7.15-1.4.x86_64.rpm .............................[完成]
正在取出 套件 libpostproc51-0.7.15-1.4.x86_64
                                            (8/18),  22.0 KiB (已解開  38.3 KiB)
正在取出: libpostproc51-0.7.15-1.4.x86_64.rpm ...........................[完成]
正在取出 套件 libavcodec52-0.7.15-1.4.x86_64
                                            (9/18),   2.2 MiB (已解開   6.5 MiB)
正在取出: libavcodec52-0.7.15-1.4.x86_64.rpm ..............[完成 (448.5 KiB/s)]
正在取出 套件 libxine2-codecs-1.2.3-84.1.x86_64
                                           (10/18), 502.3 KiB (已解開   1.5 MiB)
正在取出: libxine2-codecs-1.2.3-84.1.x86_64.rpm ...........[完成 (190.5 KiB/s)]
正在取出 套件 k3b-codecs-2.0.2-15.48.x86_64
                                           (11/18),  51.4 KiB (已解開 195.6 KiB)
正在取出: k3b-codecs-2.0.2-15.48.x86_64.rpm ................[完成 (18.2 KiB/s)]
正在取出 套件 libavformat52-0.7.15-1.4.x86_64
                                          (12/18), 404.8 KiB (已解開 1010.2 KiB)
正在取出: libavformat52-0.7.15-1.4.x86_64.rpm .............[完成 (130.7 KiB/s)]
正在取出 套件 libavfilter1-0.7.15-1.4.x86_64
                                           (13/18), 167.7 KiB (已解開 430.9 KiB)
正在取出: libavfilter1-0.7.15-1.4.x86_64.rpm ............................[完成]
正在取出 套件 gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.2.x86_64
                                           (14/18), 142.4 KiB (已解開 291.0 KiB)
正在取出: gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.2.x86_64.rpm .......[完成]
正在取出 套件 libdvdcss2-1.2.12-1.71.x86_64
                                           (15/18),  19.5 KiB (已解開  38.5 KiB)
正在取出: libdvdcss2-1.2.12-1.71.x86_64.rpm .............................[完成]
正在取出 套件 libsidplay1-1.36.59-154.1.1.x86_64
                                           (16/18),  76.7 KiB (已解開 272.9 KiB)
正在取出: libsidplay1-1.36.59-154.1.1.x86_64.rpm ........................[完成]
正在取出 套件 gstreamer-0_10-plugins-ugly-0.10.19-10.26.x86_64
                                           (17/18), 133.2 KiB (已解開 356.1 KiB)
正在取出: gstreamer-0_10-plugins-ugly-0.10.19-10.26.x86_64.rpm [/ (104.1 KiB/s)正在取出: gstreamer-0_10-plugins-ugly-0.10.19-10.26.x86_64.rpm [完成 (52.6 KiB/s)]
正在取出 套件 gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-10.26.x86_64
                                           (18/18), 172.9 KiB (已解開 532.4 KiB)
正在取出: gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-10.26.x86_64.rpm [正在正在取出: gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-10.26.x86_6[- (70.1 Ki正在取出: gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-10.26.x86_64.rpm [完成]
( 1/18) 正在安裝: libavutil50-0.7.15-1.4 ................................[完成]
( 2/18) 正在安裝: libx264-129-0.129svn20130224-2.1 ......................[完成]
( 3/18) 正在安裝: lame-3.99.5-1002.1 ....................................[完成]
( 4/18) 正在安裝: librtmp0-2.4.git20121102-1.1 ..........................[完成]
( 5/18) 正在安裝: libxine2-1.2.3-84.1 ...................................[完成]
( 6/18) 正在安裝: k3b-2.0.2-15.48 .......................................[完成]
( 7/18) 正在安裝: libswscale0-0.7.15-1.4 ................................[完成]
( 8/18) 正在安裝: libpostproc51-0.7.15-1.4 ..............................[完成]
( 9/18) 正在安裝: libavcodec52-0.7.15-1.4 ...............................[完成]
(10/18) 正在安裝: libxine2-codecs-1.2.3-84.1 ............................[完成]
(11/18) 正在安裝: k3b-codecs-2.0.2-15.48 ................................[完成]
(12/18) 正在安裝: libavformat52-0.7.15-1.4 ..............................[完成]
(13/18) 正在安裝: libavfilter1-0.7.15-1.4 ...............................[完成]
(14/18) 正在安裝: gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.2 ..........[完成]
(15/18) 正在安裝: libdvdcss2-1.2.12-1.71 ................................[完成]
(16/18) 正在安裝: libsidplay1-1.36.59-154.1.1 ...........................[完成]
(17/18) 正在安裝: gstreamer-0_10-plugins-ugly-0.10.19-10.26 .............[完成]
(18/18) 正在安裝: gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-10.26 ..[完成]

 

但是安裝完成後,進入 totem影片播放軟體播放MP4檔案時,仍舊出現要安裝H.264 decoder 與MPEG4-AAC decoder的訊息,當點按安裝鈕並進行安裝時,又會出現錯誤訊息:

無法同時安裝 gstreamer-plugins-good-1.0.5-2.1.5.x86_64 和 gstreamer-plugins-good-1.0.7-2.5.x86_64
無法同時安裝 gstreamer-plugins-bad-1.0.5-2.1.1.x86_64 和 gstreamer-plugins-bad-1.0.7-2.5.x86_64
gstreamer-plugins-bad-orig-addon-1.0.7-2.5.x86_64 需要 libmpeg2encpp-2.0.so.0()(64bit),但無法提供此需求

因此終止安裝的情況。

 

文章標籤
創作者介紹

xx3d2ybnf-不圖3日但2年精進勇者不懼的部落格

xx3d2ybnf 發表在 痞客邦 留言(0) 人氣()